Skip to end of metadata
Go to start of metadata

INTRODUCTION TO COMMON FUNCTIONS AND COMMANDS

This Chapter describes the Common Functions and Commands in Compiere. You will find that Compiere provides an adaptable and user friendly application to meet your business needs.

LOGIN

To open the Compiere Client Application, you can click the Compiere icon on your desktop.

When you are not connected to the Internet, you will be asked if you want to be connected to the Internet. The Internet connection is required for accessing the Online Help files at Compiere.org.

To open the Compiere Web Application, Start your application server and open the Mozilla, Firefox browser. For the browser URL enter compiere.com/apps/Compiere.html prefixed by the server hosting the application.


 
Log in as the Administrative User, the End User, or as SuperUser or System (case sensitive) and the password System. Compiere remembers your entries and selections. Choose the Language and click OK.

The difference between SuperUser and System is as follows: If you log in as System, you can only manage the Tenant System. If you log in as a SuperUser, you have the choice of managing any of the Tenants on the System, including System.

Important: The language you select determines which date format will be used by the system.

If you select the Select Role check box,  the values used last time a login was performed are displayed and you can change these as desired. To open the Tenant System choose System Administrator as your Role.

Important: For testing purposes you should select GardenAdmin as your Role. The Tenant will then automatically default to GardenWorld.

The Organization will default to HQ and the Warehouse will default to Standard. The Date will default to the current date. This is the default date used for all documents. The Printer must be a printer defined for this Tenant and may be a network printer. It is the printer used for all documents and reports.

While logging into the Client Application, you can access help at anytime by Clicking on the Help tab.

MENU FUNCTIONS

The Compiere menu shows all tasks available for your selected role. In the search field in the left navigation panel type in 'Sales'. As you type the system will display the executable menu items that match the character strings. 

Note:  Folders are not included in the search results

To open the current menu item press  the Enter key or double click the menu item.

Favorites can be defined for frequently used menu items such as Sales Order or Expense Report. Favorites appear in the left navigation panel and can be expanded or collapsed. To add menu items to Favorites, click the 'New Record'icon to the right of Favorites in the left navigation panel to pull down a pick list and select the item you would like add as a shortcut from the list. 

Menu Icons

Each menu item has an icon which indicates the type of function the window performs.

The Window icon indicates a Window. A window is where a record is defined or data is entered such as Sales Order or Tax Category.

The Report icon indicates a Report. A report will generate an on-screen report which can be modified and printed such as Invoice Summary.

The Process icon indicates a Process. A process can be thought of as a job or task that runs in the database or on the server such as Generate Invoices.

The Workflow icon indicates a Workflow. A Workflow defines a series of steps needed to accomplish a goal. 

Note: Windows, Processes, Reports, and Workflows will be covered in more detail later in this chapter.

COMMANDS AND BUTTONS

Every window in Compiere has a common look and feel. While the contents or fields of a window may change some areas of the window will remain constant. These include the Toolbar, Menu, Context (for specific fields), and Dialogs.

Attachments
Compiere provides the ability to attach files to any record in the system. You can attach a single file or multiple files. The attached files are stored in the database so there is no need to distribute files. This may be used for attaching scanned documents to Order or Invoices or to include schematics or diagrams to a product.

Simply attach a document to a record by selecting the Attachment button located on the tool bar.

A dialog window displays. Enter the location of the file or select Browse to locate the file. Select the OK button to add a file or files.  Repeat this process if you have additional files to attach.  To view an attached file select the Open button.

The file will load.

Note: File types of .pdf, .png, .gif, and .jpg will automatically. Any other file types require the appropriate application to view them.

Select the Delete button to delete the Attachment

If a record has an Attachment, the Attachment button will appear differently in the toolbar and include a number indicating the number of files attached.
All Users who have access to this record will have access to the attachments.

E-mail to Support

Directly from the upper right tab you can send an email to your support team (or any valid email address).

The From address is taken from the email address defined for the User entered when logging into the system. Select the To arrow to see a list of all email addresses defined in the System, or simply enter the desired email.

The text of the Email contains the values found in the Context tab of the Preferences window. Select an User/Contact and click the OK button.

You can add more addresses if desired by separating them with a semicolon.

When you click the OK button to send the message, a dialog window will display to indicate that the message was successfully sent.

WORKFLOW

Compiere has two types of Workflows, General Workflow, and Document Process Workflow. The General Workflows are started and performed via the menu. They are defined to assist the user in walking though a task like Business Partner Setup or Initial Tenant Set Up Review. The Document Process Workflows are started when a Document is processed. These workflows may be 'invisible' to the user as in Sales Order, or they may require the User to perform an action for the process to be completed. Both may be defined in Compiere, although the process of defining Workflows is not covered here as it focuses on the use of Workflows.

General Workflow

A General Workflow is a series of steps which may have to be carried out one after the other. Open any workflow window (e.g. Business Partner Setup). You will see references to pre-defined workflows throughout this manual as we discuss different tasks. As an example look at the Initial Tenant Setup Review workflow. You open it by selecting System Admin, Tenant Rules, Initial Tenant Setup Review in the menu.

As the Workflow loads, you will notice in the upper half of the window there is a graphical illustration of the Workflow. You can easily review the steps carried out during the setup. In the lower part of the window you see the explanation of the relevant workflow step or the node. To navigate through the different steps and open the appropriate window click on the specific Workflow icon.

Document Process Workflow

Document Process Workflows are started when a document is Processed. A document in Compiere is a Sales Order, Invoice, Material Receipt, GL Journal, Bank Statement, etc. The pre-defined Document Process Workflows are basically transparent to the user.

For example, there is a workflow for processing a Point of Sale (POS) Order. A POS order is entered and when it is processed a Shipment and Invoice are automatically generated. This is in contrast to a Standard Order where the Shipment and Invoice are generated in a batch process. It is the workflow which defines which control what documents are generated and what each process will do. In general, we suggest that you do not modify the existing Document Process Workflows other than to add tasks to them (e.g. approval for a PO over a specific amount).

Compiere includes a 'sample' user defined Document Process Workflow. We will use this as an example of how an end user would interact with Compiere when workflows are in place.

The Requisition Workflow has the following Steps or Nodes:

  • A Requisition Document is entered.
  • If the total amount is greater than 100 it must be approved.
  • After it is approved a report is generated for the Requisition.
  • The Report is forwarded to the User who entered the Requisition.
  • The User may acknowledge that the Report has been received.
  • The User reviews the Requisition.
  • The Requisition may be closed.

We will begin with the Requisition by clicking on Requisition from the Main Menu.

The Requisition window may be used to enter requests for purchases to be made. We will discuss this window in general terms only as the specific of the fields and their functions are discussed in detail in later chapters.

Note that the User/Contact is GardenUser. This is the person responsible for this workflow. They will receive any notices regarding this workflow.

Select the Requisition Line to enter the products being requested.

A line is entered for each product.

When all lines have been entered, return to the Requisition tab and select the Complete button. This is the Process that will start the Workflow.

When the Process has finished, note the Status of our Requisition.

The Document Status is In Progress and the message text shows a message of Suspended.

If you select the Complete button, you will get a message indicating the there is an active workflow, what the next step is (Please Approve Requisition) and the user the step is assigned to (GardenAdmin)

You can see details of this Workflow by opening the Workflow Process window.

Select the Activity tab to view information on the specific activities for this Workflow.

The Workflow Process is Process Requisition and the Node is Requisition Approval. The Workflow State is Suspended. This indicates that the Workflow has been Suspended in the Approval step or node.

The User/Contact is GardenAdmin which indicates that this is the user who must approve this Requisition.

You may select the Manage Activity button to change the Workflow Responsible, User/Contact, or Abort the Activity.

We now know that GardenAdmin must approve this Requisition. This is because the Role for GardenUser has been defined as the following.

For this Role, the Approve own Documents check box has not been selected and the Supervisor is set to GardenAdmin. Any documents entered by a User with the Garden User Role must be approved by GardenAdmin.

For additional information on Roles and Users, refer to the Security Chapter.

We now log in as GardenAdmin to approve this Requisition. 

You can view all workflow activities assigned to you by opening Workflow Activities.

The Description and Comments are copied from the workflow definition.

The History records displays the different steps that have been executed along with the date/time stamp.

You may enter any Message to include in your response.  For example, you may want to enter a reason you are denying a requisition.

You can use the Zoom button at the top to open the document (in this example the Requisition) in a new window.

From this window you can either approve (answer Yes) or deny (answer No) or Forward the workflow to another user.  This re-assigns the Workflow Activity to this user.

When are finished click Submit which will progress the workflow to the next step.

If you have multiple activities assigned, use the forward and back arrows at the top of the window to navigate though all activities.

If your user permissions allow, you can view all workflow activities by opening Workflow Activities (all).

You may also access any Open Activities assigned to a User by selecting Workflow Activities from the menu. If you have the appropriate privileges you may also see all Workflow Activities by selecting Workflow Activities (all) from the menu.

If we return to GardenUser menu, select Notices from the View tab.

The Description indicates that this Notice is a Detail of Open Requisition Information.

Select the Attachment button on the tool bar to view the report.

Garden User may acknowledge the receipt of the report by selecting the Acknowledge check box.

You may also access any Notices assigned to a User by selecting Notices from the menu.

There is still one Activity assigned to the User. Select Workflow Activities tab on the menu.

Select the Verify completed Requisition button to complete the Workflow. You may add a message if desired.

Finally, use the Zoom button the zoom to the Requisition and close it if desired

Select the Close button to Close this Requisition.

This workflow is an example of how workflows may be defined. How your company uses workflows and how the users interact with them will be dependent upon their definition.

Compiere ensures that two users do not attempt to initiate the same workflow. If a user attempts to start a Document Process Workflow that has already been started the following message will display.

The Message indicates that a Workflow already exists and at what stage it is in. This message was generated when a User attempted to Process the Requisition entered that was awaiting Verification by GardenUser.

HELP FUNCTIONS

Screen Help

Compiere provides Help on the windows you are in. Just open the Help Menu in any window and select Help or press F1.

A Help window opens and displays all the information about the actual window you are in. The Help window includes Window information, Tab, and Field information. You can scroll the Help window or click on the links.

The Window information displays a short description of the window. The Tab show information for each tab and the fields within that tab.

The Field information displays a short description of the selected field.

Online Training
Under http://www.compiere.com/online you have the possibility to attend Online Training.

WINDOW FUNCTIONS

Compiere supports different window context functions, which allow you to enter information very easily from the window you are in. In our example, we look at a sales order. You open the Sales Order window by pressing Ctrl-Enter (Alt-Enter or Shift-Enter) in the yellow search field, by double-clicking on the term in the menu tree or clicking on the shortcut in your menu

Value Preference

The Value Preference function in the context menu allows you to set your preferences directly within the window you have open.

The Sales Order window appears with the Preferences/defaults you set for your Tenant (GardenWorld) and Organization (HQ). Optional fields have a white background; mandatory fields have a light background. Reddish fields are mandatory fields that still require a value.

To set your preferences fill the field or select the desired value from the drop down-list (for example, change the field Target Document Type from Standard to POS Order), then in the Client Application, right-click on the field and select Value Preference from the menu. In the Web Application, simply click on the field label and select Value Preference.


 
Select the scope (For all/specific Organization, User, Window) and press OK. Your new default value will now be POS Order in the Order window.

The level for which a User may set Value Preferences is defined in the Role.

For additional information on Roles, refer to the Security Chapter.

New Record

The New Record function in the context menu allows you to create a new Business Partner directly within the current window. You would normally create a new Business Partner by importing it or by entering it in the Business Partner window. There may be times when entering a document you need to enter a new Business Partner quickly.

Using the Client Application, in the Business Partner field, use the right mouse button and select New Record. In the Web Application, simply click on the Customer  field label and select New Customer.


 
Enter the customer information. To enter the address, click on the Location button next to the Location/Address field.

The Enter new Location/Address window appears. Enter the address information and click OK to continue. The sales order is then automatically updated with the new information.

All other field values for the new business partner are defaulted from the Default Business Partner defined for this Tenant. Any Business Partner created with this method can always be modified directly in the Business Partner window.

Zoom

The Zoom function in the context menu allows you to "zoom" directly to the window where this entity is defined. You can then determine which value you want to use or you may create a new record.

You may Zoom to the window clicking on a field label and selecting Zoom.

The Window from the field that was clicked opens. If the 'zoom from' field has a selection, the Zoom window would query the selected record automatically. If the 'zoom from' field is blank, a New Record is automatically opened in the window.

You can add a new record here if desired.

If you have modified the record or created a new record, click the Save button on the toolbar and close the window.

Note: All security rules are enforced with Zoom.  If you cannot access a particular record you cannot Zoom to it.

ReQuery

If using Zoom, you added a new record, it is not reflected in your drop down list (as the database is queried when the window is opened).  There is no need to refresh the window to get any new values. Simply click on the field and select ReQuery.  Newly added records will now be available for selection.

Search and Info

Info windows are display windows which provide an easy way to see data related to a specific record (e.g. Business Partner) which may be stored in multiple records.  For example, in the Business Partner Info window you can see the Business Partner Name, Contact, Open Balance and can also see what has been sold or purchased and at what price. You can also Zoom to a selected record where you can perform maintenance.

Search is used in windows when there are a large number of records available for select in a field and you want to narrow down the list of records that are returned.

For example, in the Sales Order window you can enter unique search criteria in the Business Partner field (e.g. enter C&W ), and the search returns one record only,the actual Search window is not opened.

If you use a wild-card '%' in the Search field, the Business Partner Info Search window is opened displaying a list of all Business Partners (this can also be achieved by clicking the search icon next to the field).

You can search based on the Business Partner Key, Name, Contact, Email, Phone, or Zip Code. Select the Customers only check box if you want to see just those Business Partners that are defined as Customers.

Now select New Record for the Order Line.

In the Product field, enter %Bush with 'bush' [case is ignored] in the search key) and press Enter.

You can view product availability and pricing based on the customer or order price list. You can also search based on the Product Name, UPC/EAN or SKU number. You can also see what stock is available in different warehouses.

Select a product by clicking on it and click OK or just double-click on the line.

Within an info window, if the list of options for a given field is long, a general Search field is used rather than a drop down list. For example, in the Order Info window, the Business Partner parameter in the search criteria is a search field.

High Volume Windows

Some windows in Compiere are designated as High Volume windows. These include Business Partners and Products. As you may have thousands of records for these windows, Compiere will display a Find Record window when one of these menu items is selected.

You can enter all or part of the Key, Name or Description to reduce the number of records returned.

If you select the Search Button with no search criteria, all records are displayed.


 
Select the New Record button if you want to display the screen in new record mode with just the default values populated.
You can also select the Advanced tab to enter more advanced search criteria.
All fields defined for the record are available for searching. Select the Column, Operator, and Query Value. Select the To Query Value if a range Operator is selected. If you want to add more search criteria select the Save button to save the first query line and select the New Record button to add the additional criteria. All lines will be evaluated using 'and' logic, so all conditions must be met.

Select the OK button to execute the search and return the source window with the records that meet the search criteria.

Select the Cancel button to cancel the search and return all records.

Note: Your System Administrator can invoke this behavior on other windows where you may have many records by selecting the High Volume check box in the data dictionary.  Similarly, they can also deselect the High Volume check box for windows if appropriate for your company.

The standard SQL operands are supported.  The list of available operands will vary depending upon the field type.  For example, if a list field is selected then the only operands available are '=' and '!=', if a text field is selected there are many more options.

The following are the supported operands.

=

Equal to

!=

Not Equal to

~

Like

!~

Not Like

>

Greater Than

>=

Greater Than or Equal to

<

Less Than

<=

Less Than or Equal to

>-<

Between

Saved Queries

If you want to save the query criteria for a window for future use select the Find Record button from the toolbar.

Note: This is the same window that appears for high volume windows as described above.

Select the Advanced Tab and enter the Query Criteria. To save the Query for future use, enter a description in the text box and select Save.

You can retrieve the query by accessing My views in the Web Application when you are in the appropriate window.

All Saved Queries for this window will display. When the desired query is selected it will be executed and return the appropriate rows.

Record Info

Every window in Compiere provides you with current Record information. You can access this information by clicking on the record count in any window.

 

Click on the record count to display the person who created and updated this record and when.

 

This window may also display an audit trail of what fields were changed, the new and old values, along with the Role that updated the record and the date.

This functionality may be enabled at a Table or Role level. To enable at a Table level selected All or Deletes and Updates in Maintain Change Log  for the desired table(s).

Note: The Table and Column window is accessible only by the System Administrator Role.

To enable at the Role level selected the Maintain Change Log check box for the desired Role(s).

In this example any updates made by a User logged into Compiere with the Role of GardenWorld Admin will be logged.

If you are logging changes, they can be un-applied and re-applied using the Change Audit and Session Audit windows.

It is suggest that you use care when determining what tables and users to audit as it can create many transactions.  It is generally reserved for sensitive data (like Bank Account) or to identify undesirable behavior by an individual.

USER PREFERENCES

Preference Tab

User Preferences allow you to determine the display of the Tenant and how it will react to specific user actions. User Preferences can be accessed by selecting the Preference Tab and User Preferences..

User Interface Theme

The User Interface Theme button allows you to select the look and feel of Compiere. You can select different styles and colors and preview your selection prior to saving.

Printer

The Printer field allows you to select a printer to be used for documents and reports. It will override the value entered when logging in to Compiere.

Automatic Commit

If the Automatic Commit check box is selected, your changes are automatically saved when navigating within a single tab. It will also save the record when moving from a parent to child tab (e.g. from Order Header to Order Line).

Show Advanced Tabs

If you selected the Show Advanced Tabs check box, Compiere will show these tabs in each window as appropriate. These tabs appear in windows like Orders, Shipment/Receipt, Invoice, Payment and Inventory. They are display only tabs and provide information generally necessary only when trying to resolve a problem. Most users will not have this enabled while developers may.

Show Accounting Tabs/Show Translation Tabs

If you selected the Show Accounting Tabs/Show Translation Tabs check boxes, Compiere will show these tabs in each window as appropriate. System Administrators will most likely have these check boxes selected, while most users will not. It may also be used by advanced users for audit trail purposes.

Always Print Preview

Always Print Preview check box should be selected. Compiere will displays preview screen prior to printing any document, report or screen.

Stock Level Warning

When Stock Level Warning is checked, a warning message is displayed when the stock level in the warehouse is less than required.

Direct Browser Print

When Direct Browser Print is checked, the user can directly print the documents from the browser.

Date

The Date field allows you to select a date to be used for documents. It will override the value entered when logging in to Compiere. An example of when this may be used is an Order Entry clerk has to enter a batch of Purchase Orders from the previous day.  If the date in preferences is set to the prior day, it clerk would not have to remember to update the date for each new record.  When the batch of the prior day's Purchase Orders have been entered, she can go back into preferences and set the date to the current day.

User Preferences may only be set by a User in a Role with a Preference Level set to Tenant. You may prevent the update of Preferences by setting the appropriate Security level.

For additional information on Roles, refer to the Implementation and Basic Settings Chapter.

For additional information on Security, refer to the Security Chapter.

Context

The Context option is accessed in the Preferences tab and provides information on what the system is currently 'aware of'. It is generally used if you are developing your own windows or processes in Compiere.

COMMON FIELDS

Some fields in Compiere are displayed very often. Here are descriptions of these fields.

Active

One common field is the Active check box. There are two methods of making records unavailable in the system. One method is to delete the record; the other is to de-activate the record. A de-activated record is not available for selection, but available for reports. There are two reasons for de-activating and not deleting records:

  • The system requires the record for audit purposes.
  • The record is referenced by other records. (For example, you cannot delete a Business Partner if there are existing invoices for this partner record.) You de-activate the Business Partner and prevent the record from being used for future entries.

Tenant

This is the Tenant for this installation. A Tenant is a company or legal entity.

Default

The Default check box specifies if this record will be used as a default value for new records.

Description

The Description is an optional short description of the record. A Description is limited to 255 characters.

Document No

The Document No is usually automatically generated by the system and determined by the document type of the document. If the document is not saved, the preliminary number is displayed in < >.

If the document type of your document has no automatic document sequence defined, the field is empty if you create a new document. This is for documents which usually have an external number (like vendor invoices). If you leave the field empty, the system will generate a document number for you.

The document sequence used for this number is defined in the Document Sequence window available in the Main Menu. Its name is DocumentNo_, where TableName is the actual name of the table (e.g. C_Order)

Name

The Name is the alphanumeric identifier of the entity. The Name of an entity (record) is used as a default search option in addition to the search key. The name is up to 60 characters in length.

Organization

This is the organizational entity within the Tenant. An Organization is a unit of your Tenant or legal entity - examples are store, department.

Summary Level

The Summary Level check box specifes that the entity is a Summary entity. Summary entities are used in the Product trees and are for reporting purposes only. They have no values associated with them and would not appear on price lists, stock replenishments etc.

Translated

The Translated check box specifies if this column is translated.

Labels
  • None
  1. Jun 21, 2008

    Just a note - the above are more relevant to the STD version since many of the above items are missing from the PRO version.

     i.e.
    in the Pro ver - Auto Print cannot be disabled, which is very frustrating.